auxiliary bus driver · Supported
Maintainers
- M Greg Kroah-Hartman <gregkh@linuxfoundation.org>
- M "Rafael J. Wysocki" <rafael@kernel.org>
- M Danilo Krummrich <dakr@kernel.org>
- R Dave Ertman <david.m.ertman@intel.com>
- R Ira Weiny <iweiny@kernel.org>
- R Leon Romanovsky <leon@kernel.org>
Paths
- F
Documentation/driver-api/auxiliary_bus.rst - F
drivers/base/auxiliary.c - F
include/linux/auxiliary_bus.h - F
rust/helpers/auxiliary.c - F
rust/kernel/auxiliary.rs - F
samples/rust/rust_driver_auxiliary.rs
Last 30 days
Most active threads (last 7 days)
-
WARM1d
[PATCH v9 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
2026-07-23 02:11 · 1 reply in 7d · Alvin Sun <hidden>
Active reviewers (last 30 days)
-
Gary Guo <gary@garyguo.net>
4 attestations (2 Reviewed-by, 2 Suggested-by) · last on 2026-07-23 -
Danilo Krummrich <dakr@kernel.org>
2 attestations (2 Acked-by) · last on 2026-07-23 -
Alice Ryhl <aliceryhl@google.com>
1 attestation (1 Reviewed-by) · last on 2026-07-23
Recent patches
Most-recent 30 patches in this subsystem on driver-core (capped at 30), ordered by date desc.
-
WARM1d
REVIEWED: 31 (31M) [PATCH v9 01/10] rust: module: move module types into `module.rs`
2026-07-23 · Alvin Sun <hidden> -
COOLING12d
REVIEWED: 19 (19M) [PATCH v8 01/10] rust: module: move module types into `module.rs`
2026-07-13 · Alvin Sun <hidden> -
COLD27d
[PATCH] rust: device_id: rename IdTable::as_ptr to as_raw_id_table()
2026-07-02 · Alice Ryhl <aliceryhl@google.com> -
COOLING12d
[PATCH v2 06/11] rust: driver: centralize device ID handling
2026-06-29 · Gary Guo <gary@garyguo.net> -
COOLING12d
[PATCH v2 08/11] rust: driver: store pointers in `DeviceId`
2026-06-29 · Gary Guo <gary@garyguo.net> -
COOLING12d
[PATCH v2 07/11] rust: driver: remove `$module_table_name` from `module_device_table`
2026-06-29 · Gary Guo <gary@garyguo.net> -
COOLING12d
[PATCH v2 03/11] rust: pci: use `Option<&IdInfo>` for device ID info
2026-06-29 · Gary Guo <gary@garyguo.net> -
COLD30d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COLD30d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COLD31d
REVIEWED: 12 (12M) [PATCH v5] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COLD32d
REVIEWED: 15 (15M) [PATCH v7 01/10] rust: module: move module types into `module.rs`
2026-06-27 · Alvin Sun <hidden> -
COLD17d
REVIEWED: 9 (9M) [PATCH v4 4/7] rust: auxiliary: sample: demonstrate ForLt with invariant Mutex type
2026-06-26 · Danilo Krummrich <dakr@kernel.org> -
COLD17d
REVIEWED: 9 (9M) [PATCH v4 3/7] rust: auxiliary: add registration_data_with() for ForLt types
2026-06-26 · Danilo Krummrich <dakr@kernel.org> -
COLD17d
REVIEWED: 9 (9M) [PATCH v4 1/7] rust: types: rename ForLt to CovariantForLt
2026-06-26 · Danilo Krummrich <dakr@kernel.org> -
COLD22d
REVIEWED: 34 (33M) [PATCH v19 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-26 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD33d
REVIEWED: 34 (33M) [PATCH v18 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-25 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD32d
REVIEWED: 15 (15M) [PATCH v6 01/10] rust: module: move module types into `module.rs`
2026-06-24 · Alvin Sun <hidden> -
COLD35d
[PATCH v5 1/9] rust: module: move module types into `module.rs`
2026-06-24 · Alvin Sun <hidden> -
COLD36d
[PATCH v4 1/9] rust: module: move module types into `module.rs`
2026-06-23 · Alvin Sun <hidden> -
COLD34d
[PATCH v3 4/7] rust: auxiliary: sample: demonstrate ForLt with invariant Mutex type
2026-06-18 · Danilo Krummrich <dakr@kernel.org> -
COLD34d
[PATCH v3 3/7] rust: auxiliary: add registration_data_with() for ForLt types
2026-06-18 · Danilo Krummrich <dakr@kernel.org> -
COLD34d
[PATCH v3 1/7] rust: types: rename ForLt to CovariantForLt
2026-06-18 · Danilo Krummrich <dakr@kernel.org> -
COLD39d
[PATCH 06/10] rust: driver: remove `$module_table_name` from `module_device_table`
2026-06-18 · Gary Guo <gary@garyguo.net> -
COLD39d
[PATCH 05/10] rust: driver: centralize device ID handling
2026-06-18 · Gary Guo <gary@garyguo.net> -
COLD39d
[PATCH 07/10] rust: driver: store pointers in `DeviceId`
2026-06-18 · Gary Guo <gary@garyguo.net> -
COLD39d
[PATCH 03/10] rust: pci: use `Option<&IdInfo>` for device ID info
2026-06-18 · Gary Guo <gary@garyguo.net> -
COLD34d
REVIEWED: 34 (33M) [PATCH v17 06/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-04 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD56d
[PATCH v2 4/7] rust: auxiliary: sample: demonstrate ForLt with invariant Mutex type
2026-06-03 · Danilo Krummrich <dakr@kernel.org> -
COLD56d
[PATCH v2 3/7] rust: auxiliary: add registration_data_with() for ForLt types
2026-06-03 · Danilo Krummrich <dakr@kernel.org> -
COLD56d
[PATCH v2 1/7] rust: types: rename ForLt to CovariantForLt
2026-06-03 · Danilo Krummrich <dakr@kernel.org>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
STALE156d
REVIEWED: 4 (4M) [PATCH V2] driver core: auxiliary bus: Fix sysfs creation on bind
2026-02-19 · Tariq Toukan <tariqt@nvidia.com> · 1 Reviewed-by -
STALE62d
REVIEWED: 24 (24M) [PATCH v5 03/24] rust: driver: move 'static bounds to constructor
2026-05-25 · Danilo Krummrich <dakr@kernel.org> · 2 Reviewed-by -
STALE62d
REVIEWED: 28 (28M) [PATCH v5 04/24] rust: driver: decouple driver private data from driver type
2026-05-25 · Danilo Krummrich <dakr@kernel.org> · 3 Reviewed-by -
STALE62d
REVIEWED: 28 (28M) [PATCH v5 08/24] rust: auxiliary: implement Sync for Device<Bound>
2026-05-25 · Danilo Krummrich <dakr@kernel.org> · 3 Reviewed-by -
STALE62d
REVIEWED: 25 (24M) [PATCH v5 11/24] rust: device: make Core and CoreInternal lifetime-parameterized
2026-05-25 · Danilo Krummrich <dakr@kernel.org> · 3 Reviewed-by -
STALE62d
REVIEWED: 24 (24M) [PATCH v5 12/24] rust: pci: make Driver trait lifetime-parameterized
2026-05-25 · Danilo Krummrich <dakr@kernel.org> · 2 Reviewed-by -
STALE62d
REVIEWED: 24 (24M) [PATCH v5 14/24] rust: auxiliary: make Driver trait lifetime-parameterized
2026-05-25 · Danilo Krummrich <dakr@kernel.org> · 2 Reviewed-by -
STALE62d
REVIEWED: 25 (24M) [PATCH v5 23/24] rust: auxiliary: generalize Registration over ForLt
2026-05-25 · Danilo Krummrich <dakr@kernel.org> · 3 Reviewed-by -
STALE62d
REVIEWED: 29 (28M) [PATCH v5 24/24] samples: rust: rust_driver_auxiliary: showcase lifetime-bound registration data
2026-05-25 · Danilo Krummrich <dakr@kernel.org> · 4 Reviewed-by -
COLD31d
REVIEWED: 12 (12M) [PATCH v5] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE84d
[PATCH 04/24] rust: device: generalize drvdata methods over ForLt
2026-04-27 · Danilo Krummrich <dakr@kernel.org> -
STALE84d
[PATCH 08/24] rust: auxiliary: implement Sync for Device<Bound>
2026-04-27 · Danilo Krummrich <dakr@kernel.org> -
STALE84d
[PATCH 11/24] rust: pci: make Driver trait lifetime-parameterized
2026-04-27 · Danilo Krummrich <dakr@kernel.org> -
STALE84d
[PATCH 13/24] rust: auxiliary: make Driver trait lifetime-parameterized
2026-04-27 · Danilo Krummrich <dakr@kernel.org> -
STALE84d
[PATCH 14/24] rust: auxiliary: generalize Registration over ForLt
2026-04-27 · Danilo Krummrich <dakr@kernel.org> -
STALE84d
[PATCH 15/24] samples: rust: rust_driver_auxiliary: showcase lifetime-bound registration data
2026-04-27 · Danilo Krummrich <dakr@kernel.org> -
STALE78d
[PATCH v2 07/25] rust: auxiliary: implement Sync for Device<Bound>
2026-05-06 · Danilo Krummrich <dakr@kernel.org> -
STALE78d
[PATCH v2 10/25] rust: pci: make Driver trait lifetime-parameterized
2026-05-06 · Danilo Krummrich <dakr@kernel.org> -
STALE78d
[PATCH v2 12/25] rust: auxiliary: make Driver trait lifetime-parameterized
2026-05-06 · Danilo Krummrich <dakr@kernel.org> -
STALE78d
[PATCH v2 13/25] rust: auxiliary: generalize Registration over ForLt
2026-05-06 · Danilo Krummrich <dakr@kernel.org>